巅峰霸主 > 在线帮助文档 > bootstrap4.5文档 > Download下载

bootstrap下载安装方法

时间:2020-02-29 16:01:49  来源:巅峰霸主  作者:烈火大地 点击:
摘要:bootstrap4.4.1源文件下载方法,包括安装包和npm,BootstrapCDN,.net部署,RubyGems等详细方法,快速开始,将已编译好的源代码放入到你的项目中即可……

下载bootstrap可以获得编译好的CSS和JavaScript源代码,将其放入到的你的项目之中,例如npm,RubyGems等。

编译后的CSS和JS

下载Bootstrap v4.4.1的即用型已编译代码,以轻松放入您的项目中,其中包括:

  • 编译和缩小的CSS捆绑包

  • 编译和精简的JavaScript插件

  • 这不包括文档,源文件或任何可选的JavaScript依赖项(jQuery和Popper.js)。

下载链接:https://github.com/twbs/bootstrap/releases/download/v4.4.1/bootstrap-4.4.1-dist.zip

源文件

通过下载我们的源Sass,JavaScript和文档文件,使用您自己的资产管道编译Bootstrap。此选项需要一些其他工具:

  • 用于编译CSS的Sass编译器(支持Libsass或Ruby Sass)。

  • Autoprefixer为CSS供应商前缀

如果您需要构建工具,则可以使用它们来开发Bootstrap及其文档,但它们可能不适合您自己的目的。

下载源文件:https://github.com/twbs/bootstrap/archive/v4.4.1.zip

BootstrapCDN

使用BootstrapCDN跳过下载,以将Bootstrap的已编译CSS和JS的缓存版本部署到您的项目。

<link rel="stylesheet" href="https://stackpath.bootstrapcdn.com/bootstrap/4.4.1/css/bootstrap.min.css" integrity="sha384-Vkoo8x4CGsO3+Hhxv8T/Q5PaXtkKtu6ug5TOeNV6gBiFeWPGFN9MuhOf23Q9Ifjh" crossorigin="anonymous">
<script src="https://stackpath.bootstrapcdn.com/bootstrap/4.4.1/js/bootstrap.min.js" integrity="sha384-wfSDF2E50Y2D1uUdj0O3uMBJnjuUD4Ih7YwaYd1iqfktj0Uod8GCExl3Og8ifwB6" crossorigin="anonymous"></script>

如果您使用的是经过编译的JavaScript,请不要忘记在其之前包含CDN版本的jQuery和Popper.js。

<script src="https://code.jquery.com/jquery-3.4.1.slim.min.js" integrity="sha384-J6qa4849blE2+poT4WnyKhv5vZF5SrPo0iEjwBvKU7imGFAV0wwj1yYfoRSJoZ+n" crossorigin="anonymous"></script>
<script src="https://cdn.jsdelivr.net/npm/popper.js@1.16.0/dist/umd/popper.min.js" integrity="sha384-Q6E9RHvbIyZFJoft+2mJbHaEWldlvI9IOYy5n3zV9zzTtmI3UksdQRVvoxMfooAo" crossorigin="anonymous"></script>

Package managers

几乎可以将Bootstrap的源文件拖入任何项目中。无论软件包管理器是什么,Bootstrap都将需要Sass编译器和Autoprefixer来进行与我们正式编译版本匹配的安装。

npm

使用npm软件包在您的Node.js驱动的应用程序中安装Bootstrap :

$ npm install bootstrap

require('bootstrap')将所有Bootstrap的jQuery插件加载到jQuery对象上。该bootstrap模块本身不输出任何东西。您可以通过/js/*.js在包的顶级目录下加载文件来分别手动加载Bootstrap的jQuery插件。

引导程序package.json在以下键下包含一些其他元数据:

  • sass-Bootstrap的主要Sass源文件的路径

  • style -使用默认设置(无自定义)预编译的Bootstrap非缩小CSS的路径

yarn

使用yarn软件包在您的Node.js驱动的应用程序中安装Bootstrap :

$ yarn add bootstrap

RubyGems

在您的Ruby应用程序中使用Bundler(推荐)和RubyGems在您的Ruby应用程序中安装Bootstrap,方法是将以下行添加到您的Gemfile

gem 'bootstrap', '~> 4.4.1'

有关更多详细信息,请参见gem的自述文件

Composer

您还可以使用Composer安装和管理Bootstrap的Sass和JavaScript :

composer require twbs/bootstrap:4.4.1

NuGet

如果使用.NET开发,则还可以使用NuGet安装和管理Bootstrap的CSSSass和JavaScript :

Install-Package bootstrap
Install-Package bootstrap.sass


(责任编辑:陆柏熺)
评价:
用户名: 验证码: 看不清?点击更换


关注站长自媒体 获取更多优质内容

  • 百家号
    百家号
  • 头条号
    头条号
  • 企鹅号
    企鹅号

2019-2021 ©巅峰霸主网 京ICP备12023415号-2
返回
顶部